Name:MapBuddy
 
Version:2.1.0.512
 
Publisher:Skybase Solutions
 
The following prerequisites are required:
 
  • .NET Framework 3.5 SP1
  • Microsoft .NET Framework 4 (x86 and x64)
  • Microsoft .NET Framework 4 (x86 and x64) and Update for .NET Framework 4 (KB2468871)
  • Windows Installer 4.5
If these components are already installed, you can launch the application now. Otherwise, click the button below to install the prerequisites and run the application.
 
Install
 
Skybase Solutions Customer Support    ::    ClickOnce and .NET Framework Resources